package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\_\d(.+)`)
var str = `_Delivery_20150415162602.xml`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}