using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\_\d(.+)";
string input = @"_Delivery_20150415162602.xml";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}