import Foundation
let pattern = #"^(.*ViPNet CSP( \(версия)? 4\.2\)?|\"Крип(р|т)оПро CSP\" \(?версия (4\.0|3\.9)\)?|Криптотокен (2 )?ЭП.*|Рутокен ЭЦП.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"КрипроПро CSP" (версия 4.0)
"КриптоПро CSP" (версия 3.6)
"КриптоПро CSP" (версия 3.9)
"КриптоПро CSP" (версия 4.0)
"КриптоПро CSP" версия 3.6
"КриптоПро CSP" версия 3.9
"КриптоПро CSP" версия 4.0
Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider 3.9
Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider 4.0
JCrypto SDK 2.7.3-R321
ViPNet CSP (версия 3.2)
ViPNet CSP (версия 4.2)
ViPNet CSP 4.0
ViPNet CSP 4.1
ViPNet CSP 4.2
Криптотокен ЭП (0c53000205156035)
Рутокен ЭЦП 2.0 (0c53000216296035)
Криптотокен 2 ЭП (0c53002119206034)
Криптотокен ЭП (4e3900052631304c)
Криптотокен ЭП (4e46001821075047)
Рутокен ЭЦП (4e46001839795047)
Криптотокен ЭП (4e46001951815047)
СКЗИ «Криптотокен» в составе изделия «JaCarta ГОСТ»
Средство криптографической защиты информации (СКЗИ) ViPNet CSP 4.2
Средство криптографической защиты информации ViPNet CSP 4.2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)