#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*ViPNet CSP( \(версия)? 4\.2\)?|\"Крип(р|т)оПро CSP\" \(?версия (4\.0|3\.9)\)?|Криптотокен (2 )?ЭП.*|Рутокен ЭЦП.*)"
Local $sString = ""КрипроПро CSP" (версия 4.0)" & @CRLF & _
""КриптоПро CSP" (версия 3.6)" & @CRLF & _
""КриптоПро CSP" (версия 3.9)" & @CRLF & _
""КриптоПро CSP" (версия 4.0)" & @CRLF & _
""КриптоПро CSP" версия 3.6" & @CRLF & _
""КриптоПро CSP" версия 3.9" & @CRLF & _
""КриптоПро CSP" версия 4.0" & @CRLF & _
"Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider 3.9" & @CRLF & _
"Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider 4.0" & @CRLF & _
"JCrypto SDK 2.7.3-R321" & @CRLF & _
"ViPNet CSP (версия 3.2)" & @CRLF & _
"ViPNet CSP (версия 4.2)" & @CRLF & _
"ViPNet CSP 4.0" & @CRLF & _
"ViPNet CSP 4.1" & @CRLF & _
"ViPNet CSP 4.2" & @CRLF & _
"Криптотокен ЭП (0c53000205156035)" & @CRLF & _
"Рутокен ЭЦП 2.0 (0c53000216296035)" & @CRLF & _
"Криптотокен 2 ЭП (0c53002119206034)" & @CRLF & _
"Криптотокен ЭП (4e3900052631304c)" & @CRLF & _
"Криптотокен ЭП (4e46001821075047)" & @CRLF & _
"Рутокен ЭЦП (4e46001839795047)" & @CRLF & _
"Криптотокен ЭП (4e46001951815047)" & @CRLF & _
"СКЗИ «Криптотокен» в составе изделия «JaCarta ГОСТ»" & @CRLF & _
"Средство криптографической защиты информации (СКЗИ) ViPNet CSP 4.2" & @CRLF & _
"Средство криптографической защиты информации ViPNet CSP 4.2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")