import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*ViPNet CSP( \\(версия)? 4\\.2\\)?|\\\"Крип(р|т)оПро CSP\\\" \\(?версия (4\\.0|3\\.9)\\)?|Криптотокен (2 )?ЭП.*|Рутокен ЭЦП.*)";
final String string = "\"КрипроПро CSP\" (версия 4.0)\n"
+ "\"КриптоПро CSP\" (версия 3.6)\n"
+ "\"КриптоПро CSP\" (версия 3.9)\n"
+ "\"КриптоПро CSP\" (версия 4.0)\n"
+ "\"КриптоПро CSP\" версия 3.6\n"
+ "\"КриптоПро CSP\" версия 3.9\n"
+ "\"КриптоПро CSP\" версия 4.0\n"
+ "Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider 3.9\n"
+ "Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider 4.0\n"
+ "JCrypto SDK 2.7.3-R321\n"
+ "ViPNet CSP (версия 3.2)\n"
+ "ViPNet CSP (версия 4.2)\n"
+ "ViPNet CSP 4.0\n"
+ "ViPNet CSP 4.1\n"
+ "ViPNet CSP 4.2\n"
+ "Криптотокен ЭП (0c53000205156035)\n"
+ "Рутокен ЭЦП 2.0 (0c53000216296035)\n"
+ "Криптотокен 2 ЭП (0c53002119206034)\n"
+ "Криптотокен ЭП (4e3900052631304c)\n"
+ "Криптотокен ЭП (4e46001821075047)\n"
+ "Рутокен ЭЦП (4e46001839795047)\n"
+ "Криптотокен ЭП (4e46001951815047)\n"
+ "СКЗИ «Криптотокен» в составе изделия «JaCarta ГОСТ»\n"
+ "Средство криптографической защиты информации (СКЗИ) ViPNet CSP 4.2\n"
+ "Средство криптографической защиты информации ViPNet CSP 4.2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}