import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*noted.*|.*binkie*|.*NotedBinkie*)\\s?((wha|wa|wo).+)\\s(ur|your)\\s(gamertag|gt|gamertg|GT)";
final String string = "your native language ?\n"
+ "is your native language ?\n"
+ "where are you from ?\n"
+ "where are you from @Aripaneagra ?\n\n"
+ "whats your gamertag @Aripaneagra ?\n"
+ "whats your gamertag @andi686 ?\n"
+ "whats your gamertag @andi686?\n"
+ "whats your gamertag andi686 ?\n"
+ "whats your gamertag andi686?\n"
+ "whats your gamertag @andi ?\n"
+ "whats your gamertag @andi?\n"
+ "whats your gamertag andi ?\n"
+ "whats your gamertag andi?\n\n"
+ "@notedbinkie9727 whats your gamertag ?\n"
+ "notedbinkie9727 whats your gamertag ?\n"
+ "noted whats your gamertag ?\n"
+ "@noted whats your gamertag ?\n\n"
+ "@notedbinkie9727 whats your gamertag\n"
+ "@notedbinkie9727 what's your gamertag\n"
+ "@notedbinkie9727 whats your gamertg\n"
+ "@notedbinkie9727 what's your gamertg\n"
+ "@notedbinkie9727 whats your gt\n"
+ "@notedbinkie9727 wats ur GT\n"
+ "@notedbinkie9727 wats ur gt\n"
+ "@notedbinkie9727 whats ur gt\n\n"
+ "notedbinkie9727 whats your gamertag\n"
+ "notedbinkie9727 what's your gamertag\n"
+ "notedbinkie9727 whats your gamertg\n"
+ "notedbinkie9727 what's your gamertg\n"
+ "notedbinkie9727 whats your gt\n"
+ "notedbinkie9727 wats ur GT\n"
+ "notedbinkie9727 wats ur gt\n"
+ "notedbinkie9727 whats ur gt\n\n"
+ "noted whats your gamertag\n"
+ "noted what's your gamertag\n"
+ "noted whats your gamertg\n"
+ "noted what's your gamertg\n"
+ "noted whats your gt\n"
+ "noted wats ur GT\n"
+ "noted wats ur gt\n"
+ "noted whats ur gt\n\n"
+ "binkie whats your gamertag\n"
+ "binkie what's your gamertag\n"
+ "binkie whats your gamertg\n"
+ "binkie what's your gamertg\n"
+ "binkie whats your gt\n"
+ "binkie wats ur GT\n"
+ "binkie wats ur gt\n"
+ "binki whats ur gt\n\n"
+ "@noted whats your gamertag\n"
+ "@noted what's your gamertag\n"
+ "@noted whats your gamertg\n"
+ "@noted what's your gamertg\n"
+ "@noted whats your gt\n"
+ "@noted wats ur GT\n"
+ "@noted wats ur gt\n"
+ "@noted whats ur gt\n\n"
+ "noted whats ur gta\n"
+ "binki whats ur gta\n\n"
+ "wats ur GT noted\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}