#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(.*noted.*|.*binkie*|.*NotedBinkie*)\s?((wha|wa|wo).+)\s(ur|your)\s(gamertag|gt|gamertg|GT)"
Local $sString = "your native language ?" & @CRLF & _
"is your native language ?" & @CRLF & _
"where are you from ?" & @CRLF & _
"where are you from @Aripaneagra ?" & @CRLF & _
"" & @CRLF & _
"whats your gamertag @Aripaneagra ?" & @CRLF & _
"whats your gamertag @andi686 ?" & @CRLF & _
"whats your gamertag @andi686?" & @CRLF & _
"whats your gamertag andi686 ?" & @CRLF & _
"whats your gamertag andi686?" & @CRLF & _
"whats your gamertag @andi ?" & @CRLF & _
"whats your gamertag @andi?" & @CRLF & _
"whats your gamertag andi ?" & @CRLF & _
"whats your gamertag andi?" & @CRLF & _
"" & @CRLF & _
"@notedbinkie9727 whats your gamertag ?" & @CRLF & _
"notedbinkie9727 whats your gamertag ?" & @CRLF & _
"noted whats your gamertag ?" & @CRLF & _
"@noted whats your gamertag ?" & @CRLF & _
"" & @CRLF & _
"@notedbinkie9727 whats your gamertag" & @CRLF & _
"@notedbinkie9727 what's your gamertag" & @CRLF & _
"@notedbinkie9727 whats your gamertg" & @CRLF & _
"@notedbinkie9727 what's your gamertg" & @CRLF & _
"@notedbinkie9727 whats your gt" & @CRLF & _
"@notedbinkie9727 wats ur GT" & @CRLF & _
"@notedbinkie9727 wats ur gt" & @CRLF & _
"@notedbinkie9727 whats ur gt" & @CRLF & _
"" & @CRLF & _
"notedbinkie9727 whats your gamertag" & @CRLF & _
"notedbinkie9727 what's your gamertag" & @CRLF & _
"notedbinkie9727 whats your gamertg" & @CRLF & _
"notedbinkie9727 what's your gamertg" & @CRLF & _
"notedbinkie9727 whats your gt" & @CRLF & _
"notedbinkie9727 wats ur GT" & @CRLF & _
"notedbinkie9727 wats ur gt" & @CRLF & _
"notedbinkie9727 whats ur gt" & @CRLF & _
"" & @CRLF & _
"noted whats your gamertag" & @CRLF & _
"noted what's your gamertag" & @CRLF & _
"noted whats your gamertg" & @CRLF & _
"noted what's your gamertg" & @CRLF & _
"noted whats your gt" & @CRLF & _
"noted wats ur GT" & @CRLF & _
"noted wats ur gt" & @CRLF & _
"noted whats ur gt" & @CRLF & _
"" & @CRLF & _
"binkie whats your gamertag" & @CRLF & _
"binkie what's your gamertag" & @CRLF & _
"binkie whats your gamertg" & @CRLF & _
"binkie what's your gamertg" & @CRLF & _
"binkie whats your gt" & @CRLF & _
"binkie wats ur GT" & @CRLF & _
"binkie wats ur gt" & @CRLF & _
"binki whats ur gt" & @CRLF & _
"" & @CRLF & _
"@noted whats your gamertag" & @CRLF & _
"@noted what's your gamertag" & @CRLF & _
"@noted whats your gamertg" & @CRLF & _
"@noted what's your gamertg" & @CRLF & _
"@noted whats your gt" & @CRLF & _
"@noted wats ur GT" & @CRLF & _
"@noted wats ur gt" & @CRLF & _
"@noted whats ur gt" & @CRLF & _
"" & @CRLF & _
"noted whats ur gta" & @CRLF & _
"binki whats ur gta" & @CRLF & _
"" & @CRLF & _
"wats ur GT noted" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")