using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*noted.*|.*binkie*|.*NotedBinkie*)\s?((wha|wa|wo).+)\s(ur|your)\s(gamertag|gt|gamertg|GT)";
string input = @"your native language ?
is your native language ?
where are you from ?
where are you from @Aripaneagra ?
whats your gamertag @Aripaneagra ?
whats your gamertag @andi686 ?
whats your gamertag @andi686?
whats your gamertag andi686 ?
whats your gamertag andi686?
whats your gamertag @andi ?
whats your gamertag @andi?
whats your gamertag andi ?
whats your gamertag andi?
@notedbinkie9727 whats your gamertag ?
notedbinkie9727 whats your gamertag ?
noted whats your gamertag ?
@noted whats your gamertag ?
@notedbinkie9727 whats your gamertag
@notedbinkie9727 what's your gamertag
@notedbinkie9727 whats your gamertg
@notedbinkie9727 what's your gamertg
@notedbinkie9727 whats your gt
@notedbinkie9727 wats ur GT
@notedbinkie9727 wats ur gt
@notedbinkie9727 whats ur gt
notedbinkie9727 whats your gamertag
notedbinkie9727 what's your gamertag
notedbinkie9727 whats your gamertg
notedbinkie9727 what's your gamertg
notedbinkie9727 whats your gt
notedbinkie9727 wats ur GT
notedbinkie9727 wats ur gt
notedbinkie9727 whats ur gt
noted whats your gamertag
noted what's your gamertag
noted whats your gamertg
noted what's your gamertg
noted whats your gt
noted wats ur GT
noted wats ur gt
noted whats ur gt
binkie whats your gamertag
binkie what's your gamertag
binkie whats your gamertg
binkie what's your gamertg
binkie whats your gt
binkie wats ur GT
binkie wats ur gt
binki whats ur gt
@noted whats your gamertag
@noted what's your gamertag
@noted whats your gamertg
@noted what's your gamertg
@noted whats your gt
@noted wats ur GT
@noted wats ur gt
@noted whats ur gt
noted whats ur gta
binki whats ur gta
wats ur GT noted
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}