$re = '/^[\-]{0,1}[0-9]+[\.][0-9]+|[\-]{0,1}[0-9]+$/';
$str = '5.01
5
99
153.
-5.01
-5
-99
-153.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);