#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[\-]{0,1}[0-9]+[\.][0-9]+|[\-]{0,1}[0-9]+$"
Local $sString = "5.01" & @CRLF & _
"5" & @CRLF & _
"99" & @CRLF & _
"153." & @CRLF & _
"-5.01" & @CRLF & _
"-5" & @CRLF & _
"-99" & @CRLF & _
"-153." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")