package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\-]{0,1}[0-9]+[\.][0-9]+|[\-]{0,1}[0-9]+$`)
var str = `5.01
5
99
153.
-5.01
-5
-99
-153.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}