re = /^[\w-]+\/[\w-]+(?:;\s*[\w-]+=[\w-]+)*$/
str = 'text/plain; charset=iso-8859-1; foo=bar'
# Print the match result
str.match(re) do |match|
puts match.to_s
end