package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\w-]+\/[\w-]+(?:;\s*[\w-]+=[\w-]+)*$`)
var str = `text/plain; charset=iso-8859-1; foo=bar`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}