$re = '/^[\w-]+\/[\w-]+(?:;\s*[\w-]+=[\w-]+)*$/';
$str = 'text/plain; charset=iso-8859-1; foo=bar';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);