re = /[^\w\sáéíóúÁÉÍÓÚñÑ0-9\.\:\,\¿\?\"¡!@#\/]/m
str = '"Hola, cómo estás? 😀 123:00,00 ¿Cómo estás? ¡Hola! @username #hashtag /ruta"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end