package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\w\sáéíóúÁÉÍÓÚñÑ0-9\.\:\,\¿\?\"¡!@#\/]`)
var str = `"Hola, cómo estás? 😀 123:00,00 ¿Cómo estás? ¡Hola! @username #hashtag /ruta"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}