$re = '/([0-9]+)\n([0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{3}) --> ([0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{3})\n(.*?)\n\n/s';
$str = '1
00:01:34,769 --> 00:01:36,168
FamÃlia Soprano
2
00:01:36,304 --> 00:01:37,737
Peso
3
00:01:50,117 --> 00:01:53,780
Ela é dançarina. Broadway,
shows de verão, essas coisas.
4
00:01:53,955 --> 00:01:56,924
Estava me dizendo que Ginny...
ela dançava, não é?
5
00:01:57,124 --> 00:01:59,922
Deu aula de balé anos atrás.
6
00:02:05,032 --> 00:02:08,195
- Quem é?
- Ninguém. Jersey.
7
00:02:08,369 --> 00:02:10,394
Do grupo de Ralph Cifaretto.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);