#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)([0-9]+)\n([0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{3}) --> ([0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{3})\n(.*?)\n\n"
Local $sString = "1" & @CRLF & _
"00:01:34,769 --> 00:01:36,168" & @CRLF & _
"FamÃlia Soprano" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:01:36,304 --> 00:01:37,737" & @CRLF & _
"Peso" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"00:01:50,117 --> 00:01:53,780" & @CRLF & _
"Ela é dançarina. Broadway," & @CRLF & _
"shows de verão, essas coisas." & @CRLF & _
"" & @CRLF & _
"4" & @CRLF & _
"00:01:53,955 --> 00:01:56,924" & @CRLF & _
"Estava me dizendo que Ginny..." & @CRLF & _
"ela dançava, não é?" & @CRLF & _
"" & @CRLF & _
"5" & @CRLF & _
"00:01:57,124 --> 00:01:59,922" & @CRLF & _
"Deu aula de balé anos atrás." & @CRLF & _
"" & @CRLF & _
"6" & @CRLF & _
"00:02:05,032 --> 00:02:08,195" & @CRLF & _
"- Quem é?" & @CRLF & _
"- Ninguém. Jersey." & @CRLF & _
"" & @CRLF & _
"7" & @CRLF & _
"00:02:08,369 --> 00:02:10,394" & @CRLF & _
"Do grupo de Ralph Cifaretto." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")