import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+)\\n([0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{3}) --> ([0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{3})\\n(.*?)\\n\\n";
final String string = "1\n"
+ "00:01:34,769 --> 00:01:36,168\n"
+ "FamÃlia Soprano\n\n"
+ "2\n"
+ "00:01:36,304 --> 00:01:37,737\n"
+ "Peso\n\n"
+ "3\n"
+ "00:01:50,117 --> 00:01:53,780\n"
+ "Ela é dançarina. Broadway,\n"
+ "shows de verão, essas coisas.\n\n"
+ "4\n"
+ "00:01:53,955 --> 00:01:56,924\n"
+ "Estava me dizendo que Ginny...\n"
+ "ela dançava, não é?\n\n"
+ "5\n"
+ "00:01:57,124 --> 00:01:59,922\n"
+ "Deu aula de balé anos atrás.\n\n"
+ "6\n"
+ "00:02:05,032 --> 00:02:08,195\n"
+ "- Quem é?\n"
+ "- Ninguém. Jersey.\n\n"
+ "7\n"
+ "00:02:08,369 --> 00:02:10,394\n"
+ "Do grupo de Ralph Cifaretto.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}