$re = '/window\.location\s*=\s*\"([^"]+)\"/';
$str = '<script>
<!--
window.location = "redirect_URL/index.php"
-->
</script>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);