#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "window\.location\s*=\s*\"([^"]+)\""
Local $sString = "<script>" & @CRLF & _
"<!--" & @CRLF & _
"window.location = "redirect_URL/index.php"" & @CRLF & _
"-->" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")