using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"window\.location\s*=\s*\""([^""]+)\""";
string input = @"<script>
<!--
window.location = ""redirect_URL/index.php""
-->
</script>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}