re = /(?<!^\s)(?<=[\((\,\s?)])(FoX::)?Image\s?\*/m
str = ', Image *
,Image *
(Image *
( Image *
, FoX::Image *
,FoX::Image *
(FoX::Image *
( FoX::Image *
/* [retval][out] */ ICscImage **pVal) = 0;
Image* pImage = Image::Create();
Image* pImage = Image::Create();'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end