using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^\s)(?<=[\((\,\s?)])(FoX::)?Image\s?\*";
string input = @", Image *
,Image *
(Image *
( Image *
, FoX::Image *
,FoX::Image *
(FoX::Image *
( FoX::Image *
/* [retval][out] */ ICscImage **pVal) = 0;
Image* pImage = Image::Create();
Image* pImage = Image::Create();";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}