$re = '/(?<!^\s)(?<=[\((\,\s?)])(FoX::)?Image\s?\*/m';
$str = ', Image *
,Image *
(Image *
( Image *
, FoX::Image *
,FoX::Image *
(FoX::Image *
( FoX::Image *
/* [retval][out] */ ICscImage **pVal) = 0;
Image* pImage = Image::Create();
Image* pImage = Image::Create();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);