// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.+)\s\(.+\)\n\sCIK:\s(\d+)\s").unwrap();
let string = "ECO Building Products, Inc. (Filed by)
CIK: 0001409885 (see all company filings)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}