$re = '/^(.+)\s\(.+\)\n\sCIK:\s(\d+)\s/';
$str = 'ECO Building Products, Inc. (Filed by)
CIK: 0001409885 (see all company filings)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);