package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.+)\s\(.+\)\n\sCIK:\s(\d+)\s`)
var str = `ECO Building Products, Inc. (Filed by)
CIK: 0001409885 (see all company filings)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}