re = /\"asento\": ((?:(?!(\"vasen\"|\"oikea\")).)*),\s*$/m
str = '"asento": "vasen",
"asento": "oikea",
"asento": 42,
"asento": false,
"asento": null,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end