$re = '/\"asento\": ((?:(?!(\"vasen\"|\"oikea\")).)*),\s*$/m';
$str = '"asento": "vasen",
"asento": "oikea",
"asento": 42,
"asento": false,
"asento": null,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);