#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\"asento\": ((?:(?!(\"vasen\"|\"oikea\")).)*),\s*$"
Local $sString = ""asento": "vasen"," & @CRLF & _
""asento": "oikea"," & @CRLF & _
""asento": 42," & @CRLF & _
""asento": false," & @CRLF & _
""asento": null," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")