use strict;
my $str = ' 0 1 2
';
my $regex = qr/[0-9]{9}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";