const regex = /[0-9]{9}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{9}', '')
const str = ` 0 1 2
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);