re = /(https?:\/\/)([a-zA-Z0-9]+)\.(example.com\/product\/)([a-zA-Z0-9]+)(\/shop)\/?/
str = 'http://a.example.com/product/table/shop/
http://b.example.com/product/shoe/'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result