import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)([a-zA-Z0-9]+)\\.(example.com\\/product\\/)([a-zA-Z0-9]+)(\\/shop)\\/?";
final String string = "http://a.example.com/product/table/shop/\n"
+ "http://b.example.com/product/shoe/";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}