using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/)([a-zA-Z0-9]+)\.(example.com\/product\/)([a-zA-Z0-9]+)(\/shop)\/?";
string substitution = @"";
string input = @"http://a.example.com/product/table/shop/
http://b.example.com/product/shoe/";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}