# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
\b(
(?<!не\s)(?<!лет|или\s)(?<!года\s)(?<!работ\s)(?<!работы\s)(?<!связанны[ей]\s)
(?:
(?:со?\s
(?:
личн(?:ы(?:х|ми?)|ого|ой)|
сво(?:ими?|его|ей|их)|
собственн(?:ой|ого|ы(?:х|ми?))){0,1}\s{0,1}
(?:
легков(?:ой|ыми?)|
пасс?ажирск(?:ой|ими?)|
грузов(?:ой|ыми?)){0,1}\s{0,1}
(?:
(?:а(?:[./]?м|(?:вто(?:мобил[ея]ми?|транспортом){0,1})))|
л[ ./]?[ат]|
транспортом|
грузовик[ао]ми?|
тс|
иномарк(?:ой|ами|и)|
газел(?:ями|ью)))|
(?:наличие\s
(?:
личн(?:ых|ого|ой)|
сво(?:их|его|ей)|
собственн(?:ого|ой|ых)){0,1}\s{0,1}
(?:
легков(?:ых|ого|ой)|
пасс?ажирск(?:их|ого|ой)|
грузов(?:ых|ого|ой)){0,1}\s{0,1}
(?:
(?:а(?:[./]?м|(?:вто(?:мобил(?:я|ей)|транспорта){0,1})))|
л[ ./]?[ат]|
транспорта|
грузовик[ао]в?|
тс|
иномаро?ки?|
газел[еи]й?))|
(?:на\s
(?:
личн(?:ых|о[йм])|
сво(?:их|[её][йм])|
собственн(?:о[йм]|ых)){0,1}\s{0,1}
(?:
легков(?:ых|о[йм])|
пасс?ажирск(?:их|о[йм])|
грузов(?:ых|о[йм])){0,1}\s{0,1}
(?:
(?:а(?:[./]?м|(?:вто(?:мобил(?:ях?|е)|транспорте){0,1})))|
л[ ./]?[ат]|
транспорте|
грузовик[ае]х?|
тс|
иномарк[еа]х?|
газел[ия]х)
)
)
)\b
"""
test_str = ("Наличие личного авто\n"
"Наличие личного автомобиля\n"
"наличие личного а/м\n"
"Наличие личного автотранспорта\n"
"Наличие личного ам\n"
"наличие личного легкового автотранспорта\n"
"Наличие личного легкового автомобиля\n"
"наличие личного полноприводного автомобиля\n"
"наличие личного транспорта\n"
"наличие личного грузового\n"
"Наличие личного л/а\n"
"Наличие личного а.м\n"
"наличие личного л.а\n"
"Наличие личного легкового автомобиля\n"
"наличие личного. а/м\n"
"наличие личного автомобильного транспорта\n"
"Наличие личного легкового а/м\n"
"Наличие личного л.а\n"
"наличие личного автомобилем\n"
"наличие личного автомобиля\n"
"Наличие личного исправного а/м\n"
"наличие личного(легкового) автомобиля\n"
"наличие личного автомобиля\n"
"Наличие личного а/транспорта\n"
"наличие личного легкового авто")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.