import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\n"
+ " (?<!не\\s)(?<!лет|или\\s)(?<!года\\s)(?<!работ\\s)(?<!работы\\s)(?<!связанны[ей]\\s)\n"
+ " (?:\n"
+ " (?:со?\\s\n"
+ " (?:\n"
+ " личн(?:ы(?:х|ми?)|ого|ой)|\n"
+ " сво(?:ими?|его|ей|их)|\n"
+ " собственн(?:ой|ого|ы(?:х|ми?))){0,1}\\s{0,1}\n"
+ " (?:\n"
+ " легков(?:ой|ыми?)|\n"
+ " пасс?ажирск(?:ой|ими?)|\n"
+ " грузов(?:ой|ыми?)){0,1}\\s{0,1}\n"
+ " (?:\n"
+ " (?:а(?:[./]?м|(?:вто(?:мобил[ея]ми?|транспортом){0,1})))|\n"
+ " л[ ./]?[ат]|\n"
+ " транспортом|\n"
+ " грузовик[ао]ми?|\n"
+ " тс|\n"
+ " иномарк(?:ой|ами|и)|\n"
+ " газел(?:ями|ью)))|\n"
+ " (?:наличие\\s\n"
+ " (?:\n"
+ " личн(?:ых|ого|ой)|\n"
+ " сво(?:их|его|ей)|\n"
+ " собственн(?:ого|ой|ых)){0,1}\\s{0,1}\n"
+ " (?:\n"
+ " легков(?:ых|ого|ой)|\n"
+ " пасс?ажирск(?:их|ого|ой)|\n"
+ " грузов(?:ых|ого|ой)){0,1}\\s{0,1}\n"
+ " (?:\n"
+ " (?:а(?:[./]?м|(?:вто(?:мобил(?:я|ей)|транспорта){0,1})))|\n"
+ " л[ ./]?[ат]|\n"
+ " транспорта|\n"
+ " грузовик[ао]в?|\n"
+ " тс|\n"
+ " иномаро?ки?|\n"
+ " газел[еи]й?))|\n"
+ " (?:на\\s\n"
+ " (?:\n"
+ " личн(?:ых|о[йм])|\n"
+ " сво(?:их|[её][йм])|\n"
+ " собственн(?:о[йм]|ых)){0,1}\\s{0,1}\n"
+ " (?:\n"
+ " легков(?:ых|о[йм])|\n"
+ " пасс?ажирск(?:их|о[йм])|\n"
+ " грузов(?:ых|о[йм])){0,1}\\s{0,1}\n"
+ " (?:\n"
+ " (?:а(?:[./]?м|(?:вто(?:мобил(?:ях?|е)|транспорте){0,1})))|\n"
+ " л[ ./]?[ат]|\n"
+ " транспорте|\n"
+ " грузовик[ае]х?|\n"
+ " тс|\n"
+ " иномарк[еа]х?|\n"
+ " газел[ия]х)\n"
+ " )\n"
+ " )\n"
+ ")\\b";
final String string = "Наличие личного авто\n"
+ "Наличие личного автомобиля\n"
+ "наличие личного а/м\n"
+ "Наличие личного автотранспорта\n"
+ "Наличие личного ам\n"
+ "наличие личного легкового автотранспорта\n"
+ "Наличие личного легкового автомобиля\n"
+ "наличие личного полноприводного автомобиля\n"
+ "наличие личного транспорта\n"
+ "наличие личного грузового\n"
+ "Наличие личного л/а\n"
+ "Наличие личного а.м\n"
+ "наличие личного л.а\n"
+ "Наличие личного легкового автомобиля\n"
+ "наличие личного. а/м\n"
+ "наличие личного автомобильного транспорта\n"
+ "Наличие личного легкового а/м\n"
+ "Наличие личного л.а\n"
+ "наличие личного автомобилем\n"
+ "наличие личного автомобиля\n"
+ "Наличие личного исправного а/м\n"
+ "наличие личного(легкового) автомобиля\n"
+ "наличие личного автомобиля\n"
+ "Наличие личного а/транспорта\n"
+ "наличие личного легкового авто";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}