#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mixu)\b(" & @CRLF & _
" (?<!не\s)(?<!лет|или\s)(?<!года\s)(?<!работ\s)(?<!работы\s)(?<!связанны[ей]\s)" & @CRLF & _
" (?:" & @CRLF & _
" (?:со?\s" & @CRLF & _
" (?:" & @CRLF & _
" личн(?:ы(?:х|ми?)|ого|ой)|" & @CRLF & _
" сво(?:ими?|его|ей|их)|" & @CRLF & _
" собственн(?:ой|ого|ы(?:х|ми?))){0,1}\s{0,1}" & @CRLF & _
" (?:" & @CRLF & _
" легков(?:ой|ыми?)|" & @CRLF & _
" пасс?ажирск(?:ой|ими?)|" & @CRLF & _
" грузов(?:ой|ыми?)){0,1}\s{0,1}" & @CRLF & _
" (?:" & @CRLF & _
" (?:а(?:[./]?м|(?:вто(?:мобил[ея]ми?|транспортом){0,1})))|" & @CRLF & _
" л[ ./]?[ат]|" & @CRLF & _
" транспортом|" & @CRLF & _
" грузовик[ао]ми?|" & @CRLF & _
" тс|" & @CRLF & _
" иномарк(?:ой|ами|и)|" & @CRLF & _
" газел(?:ями|ью)))|" & @CRLF & _
" (?:наличие\s" & @CRLF & _
" (?:" & @CRLF & _
" личн(?:ых|ого|ой)|" & @CRLF & _
" сво(?:их|его|ей)|" & @CRLF & _
" собственн(?:ого|ой|ых)){0,1}\s{0,1}" & @CRLF & _
" (?:" & @CRLF & _
" легков(?:ых|ого|ой)|" & @CRLF & _
" пасс?ажирск(?:их|ого|ой)|" & @CRLF & _
" грузов(?:ых|ого|ой)){0,1}\s{0,1}" & @CRLF & _
" (?:" & @CRLF & _
" (?:а(?:[./]?м|(?:вто(?:мобил(?:я|ей)|транспорта){0,1})))|" & @CRLF & _
" л[ ./]?[ат]|" & @CRLF & _
" транспорта|" & @CRLF & _
" грузовик[ао]в?|" & @CRLF & _
" тс|" & @CRLF & _
" иномаро?ки?|" & @CRLF & _
" газел[еи]й?))|" & @CRLF & _
" (?:на\s" & @CRLF & _
" (?:" & @CRLF & _
" личн(?:ых|о[йм])|" & @CRLF & _
" сво(?:их|[её][йм])|" & @CRLF & _
" собственн(?:о[йм]|ых)){0,1}\s{0,1}" & @CRLF & _
" (?:" & @CRLF & _
" легков(?:ых|о[йм])|" & @CRLF & _
" пасс?ажирск(?:их|о[йм])|" & @CRLF & _
" грузов(?:ых|о[йм])){0,1}\s{0,1}" & @CRLF & _
" (?:" & @CRLF & _
" (?:а(?:[./]?м|(?:вто(?:мобил(?:ях?|е)|транспорте){0,1})))|" & @CRLF & _
" л[ ./]?[ат]|" & @CRLF & _
" транспорте|" & @CRLF & _
" грузовик[ае]х?|" & @CRLF & _
" тс|" & @CRLF & _
" иномарк[еа]х?|" & @CRLF & _
" газел[ия]х)" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
")\b"
Local $sString = "Наличие личного авто" & @CRLF & _
"Наличие личного автомобиля" & @CRLF & _
"наличие личного а/м" & @CRLF & _
"Наличие личного автотранспорта" & @CRLF & _
"Наличие личного ам" & @CRLF & _
"наличие личного легкового автотранспорта" & @CRLF & _
"Наличие личного легкового автомобиля" & @CRLF & _
"наличие личного полноприводного автомобиля" & @CRLF & _
"наличие личного транспорта" & @CRLF & _
"наличие личного грузового" & @CRLF & _
"Наличие личного л/а" & @CRLF & _
"Наличие личного а.м" & @CRLF & _
"наличие личного л.а" & @CRLF & _
"Наличие личного легкового автомобиля" & @CRLF & _
"наличие личного. а/м" & @CRLF & _
"наличие личного автомобильного транспорта" & @CRLF & _
"Наличие личного легкового а/м" & @CRLF & _
"Наличие личного л.а" & @CRLF & _
"наличие личного автомобилем" & @CRLF & _
"наличие личного автомобиля" & @CRLF & _
"Наличие личного исправного а/м" & @CRLF & _
"наличие личного(легкового) автомобиля" & @CRLF & _
"наличие личного автомобиля" & @CRLF & _
"Наличие личного а/транспорта" & @CRLF & _
"наличие личного легкового авто"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")