use strict;
my $str = 'Jul 11 18:09:06 ? user.info shepherd[366]: fifo: 8C:C1:21:A2:44:A3 is being marked undiscovered from state IS_IM_UNDELIV_DEST_UNDISC_MARKER_CLEAR by port removal';
my $regex = qr/((?:[a-zA-Z0-9]{2}[:-]){5}[a-zA-Z0-9]{2})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}