const regex = /((?:[a-zA-Z0-9]{2}[:-]){5}[a-zA-Z0-9]{2})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:[a-zA-Z0-9]{2}[:-]){5}[a-zA-Z0-9]{2})', '')
const str = `Jul 11 18:09:06 ? user.info shepherd[366]: fifo: 8C:C1:21:A2:44:A3 is being marked undiscovered from state IS_IM_UNDELIV_DEST_UNDISC_MARKER_CLEAR by port removal`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}