#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:[a-zA-Z0-9]{2}[:-]){5}[a-zA-Z0-9]{2})"
Local $sString = "Jul 11 18:09:06 ? user.info shepherd[366]: fifo: 8C:C1:21:A2:44:A3 is being marked undiscovered from state IS_IM_UNDELIV_DEST_UNDISC_MARKER_CLEAR by port removal"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")