re = /^false_(.*)_(.*)_(.*)$/
str = 'false_120363047103977256@g.us_B09C4B168CF6EE28B86C78C1E451E2B1_79036185705@c.us'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end