using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^false_(.*)_(.*)_(.*)$";
string input = @"false_120363047103977256@g.us_B09C4B168CF6EE28B86C78C1E451E2B1_79036185705@c.us";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}