package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^false_(.*)_(.*)_(.*)$`)
var str = `false_120363047103977256@g.us_B09C4B168CF6EE28B86C78C1E451E2B1_79036185705@c.us`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}