re = /([^\/]+)reviews([\/])?([0-9]+)?/
str = '/te_st-reviews-example-reviews/23/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end