$re = '/([^\/]+)reviews([\/])?([0-9]+)?/';
$str = '/te_st-reviews-example-reviews/23/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);