package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\/]+)reviews([\/])?([0-9]+)?`)
var str = `/te_st-reviews-example-reviews/23/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}