#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(.*,\w*).*"
Local $sString = "1,2,3,4,5,6,7,8,9,10" & @CRLF & _
",,,,,,,,," & @CRLF & _
"1,2,3,4,5,6,7,8,9,10" & @CRLF & _
"1,2,3,4,5,,,,," & @CRLF & _
",,,,,,,,," & @CRLF & _
",,,,,,,,," & @CRLF & _
",,,,,,,,," & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)