import Foundation
let pattern = #"(\[\[outlook:)([0-9A-Z]*)(\]\[)(.*)(\]\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[[outlook:000000003730C053465F314590D066368CF3097B0700AAF83E03F96EDC42918E044642DEDDB3000013E2000E0000AAF83E03F96EDC42918E044642DEDDB3000013E2EFD30000][MESSAGE: RE: Subject of the Message (Sendername Senderfirstname) 2014-08-05 19:48]]
[[http:000000003730C053465F314590D066368CF3097B0700AAF83E03F96EDC42918E044642DEDDB3000013E2000E0000AAF83E03F96EDC42918E044642DEDDB3000013E2EFD30000][MESSAGE: RE: Subject of the Message (Sendername Senderfirstname) 2014-08-05 19:48]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[[path\\outlook\\\2\.msg\3\4\5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)